Рекомендация Debian по безопасности

DSA-3596-1 spice -- обновление безопасности

Дата сообщения:
06.06.2016
Затронутые пакеты:
spice
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2016-0749, CVE-2016-2150.
Более подробная информация:

В spice, библиотеке, реализующей клиентскую и серверную части протокола SPICE, было обнаружено несколько уязвимостей. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2016-0749

    Цзин Чжао из Red Hat обнаружил ошибку выделения памяти, приводящую к переполнению динамической памяти к коде spice для работы со смарткартами. Пользователь, подключившийся к гостевой виртуальной машине через spice, может использовать эту уязвимость для вызова отказа в обслуживании (аварийная остановка процесса QEMU) или потенциального выполнения произвольного кода в основной системе с правами процесса QEMU.

  • CVE-2016-2150

    Фредиано Зиглио из Red Hat обнаружил, что злоумышленник, находящийся в гостевой системе, может получить управление соответствующим процессом QEMU в основной системе путём использования специально сформированных параметров главной плоскости.

В стабильном выпуске (jessie) эти проблемы были исправлены в версии 0.12.5-1+deb8u3.

Рекомендуется обновить пакеты spice.