Bulletin d'alerte Debian

DSA-3599-1 p7zip -- Mise à jour de sécurité

Date du rapport :
9 juin 2016
Paquets concernés :
p7zip
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 824160.
Dans le dictionnaire CVE du Mitre : CVE-2016-2335.
Plus de précisions :

Marcin Icewall Noga de Cisco Talos a découvert une vulnérabilité de lecture hors limites dans la méthode CInArchive::ReadFileItem de p7zip, un archiveur de fichiers 7zr à haut taux de compression. Un attaquant distant peut tirer avantage de ce défaut pour provoquer un déni de service ou, éventuellement, l'exécution de code arbitraire avec les droits de l'utilisateur exécutant p7zip, lors du traitement d'un fichier UDF contrefait pour l'occasion.

Pour la distribution stable (Jessie), ce problème a été corrigé dans la version 9.20.1~dfsg.1-4.1+deb8u2.

Pour la distribution testing (Stretch), ce problème a été corrigé dans la version 15.14.1+dfsg-2.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 15.14.1+dfsg-2.

Nous vous recommandons de mettre à jour vos paquets p7zip.