Рекомендация Debian по безопасности

DSA-3633-1 xen -- обновление безопасности

Дата сообщения:
27.07.2016
Затронутые пакеты:
xen
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2015-8338, CVE-2016-4480, CVE-2016-4962, CVE-2016-5242, CVE-2016-6258.
Более подробная информация:

В гипервизоре Xen были обнаружены многочисленные уязвимости. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2015-8338

    Жульен Граль обнаружил, что Xen на архитектуре ARM может содержать отказ в обслуживании в связи с длительными операциями по работе с памятью.

  • CVE-2016-4480

    Ян Бойлих обнаружил, что неправильная обработка таблицы переадресации страниц может приводить к повышению привилегий в гостевой системе Xen.

  • CVE-2016-4962

    Вэй Лю обнаружил многочисленные случаи отсутствия очистки входных данных в libxl, которые могут приводить к отказу в обслуживании.

  • CVE-2016-5242

    Аарон Корнелиус обнаружил, что некорректная обработка ресурсов на системах с архитектурой ARM может приводить к отказу в обслуживании.

  • CVE-2016-6258

    Жереми Бутильё обнаружил, что некорректная обработка таблицы переадресации страниц в PV может приводить к повышению привилегий с уровня гостевой системы до основной системы.

В стабильном выпуске (jessie) эти проблемы были исправлены в версии 4.4.1-9+deb8u6.

В нестабильном выпуске (sid) эти проблемы будут исправлены позже.

Рекомендуется обновить пакеты xen.