Debians sikkerhedsbulletin

DSA-3751-1 libgd2 -- sikkerhedsopdatering

Rapporteret den:
1. jan 2017
Berørte pakker:
libgd2
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 849038.
I Mitres CVE-ordbog: CVE-2016-9933.
Yderligere oplysninger:

En stakoverløbssårbarhed blev opdaget inde i funktionen gdImageFillToBorder i libgd2, et bibliotek til programmatisk oprettelse og behandling af grafik, udløst når ugyldige farver anvendes med truecolor-billeder. En fjernangriber kunne drage nytte af fejlen til at forårsage et lammelsesangreb (denial of service) mod en applikation, som anvender biblioteket libgd2.

I den stabile distribution (jessie), er dette problem rettet i version 2.1.0-5+deb8u8.

I distributionen testing (stretch), er dette problem rettet i version 2.2.2-29-g3c2b605-1.

I den ustabile distribution (sid), er dette problem rettet i version 2.2.2-29-g3c2b605-1.

Vi anbefaler at du opgraderer dine libgd2-pakker.