Bulletin d'alerte Debian

DSA-3808-1 imagemagick -- Mise à jour de sécurité

Date du rapport :
13 mars 2017
Paquets concernés :
imagemagick
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 856878, Bogue 856879, Bogue 856880, Bogue 857426, Bogue 844594.
Dans le dictionnaire CVE du Mitre : CVE-2016-10252, CVE-2017-6498, CVE-2017-6499, CVE-2017-6500.
Plus de précisions :

Cette mise à jour corrige plusieurs vulnérabilités dans imagemagick : divers problèmes de traitement de mémoire et cas de vérifications manquantes ou incomplètes des entrées peuvent avoir pour conséquence un déni de service ou l'exécution de code arbitraire lors du traitement de fichiers TGA, Sun ou PSD malformés.

Cette mise à jour corrige aussi des artefacts visuels lors de l'exécution de -sharpen sur des images CMYK (ils sont sans impact de sécurité, mais la correction s'est greffée sur la mise à jour de sécurité avec l'approbation des « Release Managers » de la distribution stable de Debian dans la mesure où il s'agit d'une régression dans Jessie par rapport à Wheezy).

Pour la distribution stable (Jessie), ces problèmes ont été corrigés dans la version 8:6.8.9.9-5+deb8u8.

Pour la prochaine distribution stable (Stretch), ces problèmes ont été corrigés dans la version 8:6.9.7.4+dfsg-2.

Pour la distribution unstable (Sid), ces problèmes ont été corrigés dans la version 8:6.9.7.4+dfsg-2.

Nous vous recommandons de mettre à jour vos paquets imagemagick.