Bulletin d'alerte Debian

DSA-3829-1 bouncycastle -- Mise à jour de sécurité

Date du rapport :
11 avril 2017
Paquets concernés :
bouncycastle
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2015-6644.
Plus de précisions :

Quan Nguyen a découvert qu'un manque de vérification de limite dans l'implémentation du mode Galois/Counter de Bouncy Castle (une implémentation Java d'algorithmes cryptographiques) peut avoir pour conséquence la divulgation d'informations.

Pour la distribution stable (Jessie), ce problème a été corrigé dans la version 1.49+dfsg-3+deb8u2.

Pour la prochaine distribution stable (Stretch), ce problème a été corrigé dans la version 1.54-1.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 1.54-1.

Nous vous recommandons de mettre à jour vos paquets bouncycastle.