Bulletin d'alerte Debian

DSA-3862-1 puppet -- Mise à jour de sécurité

Date du rapport :
25 mai 2017
Paquets concernés :
puppet
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2017-2295.
Plus de précisions :

La désérialisation YAML non restreinte de données envoyées au serveur par les agents dans le système de gestion de configuration de Puppet pourrait avoir pour conséquence l'exécution de code arbitraire.

Veuillez noter que ce correctif brise la compatibilité ascendante avec les agents Puppet antérieurs à la version 3.2.2 et qu'il n'existe pas de moyen sûr de la rétablir. Cela affecte les agents Puppet exécutés avec Debian Wheezy : nous recommandons une mise à jour vers la version de Puppet fournie dans wheezy-backports.

Pour la distribution stable (Jessie), ce problème a été corrigé dans la version 3.7.2-4+deb8u1.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 4.8.2-5.

Nous vous recommandons de mettre à jour vos paquets puppet.