Debians sikkerhedsbulletin

DSA-3891-1 tomcat8 -- sikkerhedsopdatering

Rapporteret den:
22. jun 2017
Berørte pakker:
tomcat8
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 864447, Fejl 802312.
I Mitres CVE-ordbog: CVE-2017-5664.
Yderligere oplysninger:

Aniket Nandkishor Kulkarni opdagede at i tomcat8, en servlet- og JSP-motor, benyttede statiske fejlsider den oprindelige forespørgsels HTTP-metode til at servere indhold, i stedet for systematisk at benytte GET-metoden. Det kunne under visse omstændigheder medføre uønskede resultater, herunder erstatning eller fjernelse af den skræddersyede fejlside.

I den gamle stabile distribution (jessie), er dette problem rettet i version 8.0.14-1+deb8u10.

I den stabile distribution (stretch), er dette problem rettet i version 8.5.14-1+deb9u1.

I distributionen testing (buster), er dette problem rettet i version 8.5.14-2.

I den ustabile distribution (sid), er dette problem rettet i version 8.5.14-2.

Vi anbefaler at du opgraderer dine tomcat8-pakker.