Bulletin d'alerte Debian

DSA-3891-1 tomcat8 -- Mise à jour de sécurité

Date du rapport :
22 juin 2017
Paquets concernés :
tomcat8
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 864447, Bogue 802312.
Dans le dictionnaire CVE du Mitre : CVE-2017-5664.
Plus de précisions :

Aniket Nandkishor Kulkarni a découvert que dans tomcat8, un moteur de servlets et JSP, les pages statiques d'erreur utilisaient la méthode HTTP de requête d'origine pour servir du contenu, au lieu d'utiliser la méthode GET systématiquement. Sous certaines conditions, cela pourrait avoir pour conséquence des résultats indésirables, y compris le remplacement ou la suppression de la page d'erreur personnalisée.

Pour la distribution oldstable (Jessie), ce problème a été corrigé dans la version 8.0.14-1+deb8u10.

Pour la distribution stable (Stretch), ce problème a été corrigé dans la version 8.5.14-1+deb9u1.

Pour la distribution testing (Buster), ce problème a été corrigé dans la version 8.5.14-2.

Pour la distribution unstable (Sid), ce problème a été corrigé dans la version 8.5.14-2.

Nous vous recommandons de mettre à jour vos paquets tomcat8.