Debians sikkerhedsbulletin

DSA-3893-1 jython -- sikkerhedsopdatering

Rapporteret den:
22. jun 2017
Berørte pakker:
jython
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 864859.
I Mitres CVE-ordbog: CVE-2016-4000.
Yderligere oplysninger:

Alvaro Munoz og Christian Schneider opdagede at jython, en implementering af Python-sproget og sømløst integreret med Java, var sårbar over for udførelse af af vilkårlig kode, udløst når der blev sendt en serialiseret funktion til deserializer'en.

I den gamle stabile distribution (jessie), er dette problem rettet i version 2.5.3-3+deb8u1.

I den stabile distribution (stretch), er dette problem rettet i version 2.5.3-16+deb9u1.

I den ustabile distribution (sid), er dette problem rettet i version 2.5.3-17.

Vi anbefaler at du opgraderer dine jython-pakker.