Säkerhetsbulletin från Debian

DSA-3910-1 knot -- säkerhetsuppdatering

Rapporterat den:
2017-07-14
Berörda paket:
knot
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 865678.
I Mitres CVE-förteckning: CVE-2017-11104.
Ytterligare information:

Clément Berthaux från Synaktiv upptäckte en sårbarhet rörande signaturförfalskning i knot, en endast-autorativ DNS-server. Denna sårbarhet tillåter en angripare att förbigå TSIG-autentisering genom att skicka skapade DNS-paket till en server.

För den gamla stabila utgåvan (Jessie) har detta problem rättats i version 1.6.0-1+deb8u1.

För den stabila utgåvan (Stretch) har detta problem rättats i version 2.4.0-3+deb9u1.

För uttestningsdistributionen (Buster) och den instabila distributionen (Sid), kommer detta problem att rättas i en senare uppdatering.

Vi rekommenderar att ni uppgraderar era knot-paket.