Debians sikkerhedsbulletin

DSA-3915-1 ruby-mixlib-archive -- sikkerhedsopdatering

Rapporteret den:
20. jul 2017
Berørte pakker:
ruby-mixlib-archive
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 868572.
I Mitres CVE-ordbog: CVE-2017-1000026.
Yderligere oplysninger:

Man opdagede at ruby-mixlib-archive, et Chef Software-bibliotek som anvendes til at håndtere forskellige arkiveringsformater, var sårbart over for et mappegennemløbsangreb. Dermed var det muligt for angribere at overskrive vilkårlige filer, ved at anvende et ondsindet tar-arkiv, indeholdende .. i dets entiteter.

I den stabile distribution (stretch), er dette problem rettet i version 0.2.0-1+deb9u1.

Vi anbefaler at du opgraderer dine ruby-mixlib-archive-pakker.