Debians sikkerhedsbulletin

DSA-3929-1 libsoup2.4 -- sikkerhedsopdatering

Rapporteret den:
10. aug 2017
Berørte pakker:
libsoup2.4
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 871650.
I Mitres CVE-ordbog: CVE-2017-2885.
Yderligere oplysninger:

Aleksandar Nikolic fra Cisco Talos opdagede en stakbaseret bufferoverløbssårbarhed i libsoup2.4, en HTTP-biblioteksimplementering i C. En fjernangriber kunne drage nytte af fejlen, ved at sende en særligt fremstillet HTTP-forespørgsel, med det formål at få en applikation, der anvender biblioteket libsoup2.4, til at gå ned (lammelsesangreb) eller potentielt udføre vilkårlig kode.

I den gamle stabile distribution (jessie), er dette problem rettet i version 2.48.0-1+deb8u1.

I den stabile distribution (stretch), er dette problem rettet i version 2.56.0-2+deb9u1.

Vi anbefaler at du opgraderer dine libsoup2.4-pakker.