Bulletin d'alerte Debian

DSA-3929-1 libsoup2.4 -- Mise à jour de sécurité

Date du rapport :
10 août 2017
Paquets concernés :
libsoup2.4
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 871650.
Dans le dictionnaire CVE du Mitre : CVE-2017-2885.
Plus de précisions :

Aleksandar Nikolic de Cisco Talos a découvert une vulnérabilité de dépassement de pile dans libsoup2.4, une implémentation en C d'une bibliothèque HTTP. Un attaquant distant peut tirer avantage de ce défaut en envoyant une requête HTTP contrefaite pour l'occasion pour provoquer le plantage d'une application utilisant la bibliothèque libsoup2.4 (déni de service), ou éventuellement exécuter du code arbitraire.

Pour la distribution oldstable (Jessie), ce problème a été corrigé dans la version 2.48.0-1+deb8u1.

Pour la distribution stable (Stretch), ce problème a été corrigé dans la version 2.56.0-2+deb9u1.

Nous vous recommandons de mettre à jour vos paquets libsoup2.4.