Debians sikkerhedsbulletin

DSA-3945-1 linux -- sikkerhedsopdatering

Rapporteret den:
17. aug 2017
Berørte pakker:
linux
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2014-9940, CVE-2017-7346, CVE-2017-7482, CVE-2017-7533, CVE-2017-7541, CVE-2017-7542, CVE-2017-7889, CVE-2017-9605, CVE-2017-10911, CVE-2017-11176, CVE-2017-1000363, CVE-2017-1000365.
Yderligere oplysninger:

Flere sårbarheder er opdaget i Linux-kernen, hvilke kunne føre til rettighedsforøgelse, lammelsesangreb eller informationslækager.

  • CVE-2014-9940

    En anvendelse efter frigivelse-fejl i driveren voltage and current regulator, kunne gøre det muligt for en lokal bruger at forårsage et lammelsesangreb eller potentielt forøge rettigheder.

  • CVE-2017-7346

    Li Qiang opdagede at DRM-driveren til VMwares virtuelle GPU'er, ikke på korrekt vis tjekkede brugerkontrollerede værdier i vmw_surface_define_ioctl()-funktionerne for øvre grænser. En lokal bruger kunne drage nytte af fejlen til at forårsage et lammelsesangreb.

  • CVE-2017-7482

    Shi Lei opdagede at RxRPC Kerberos 5-tickethåndteringskoden ikke på korrekt vis tjekkede metadata, førende til informationsafsløring, lammelsesangreb eller potentielt udførelse af vilkårlig kode.

  • CVE-2017-7533

    Fan Wu og Shixiong Zhao opdagede en kapløbstilstand mellem inotify-events og VFS-omdøbningshandlinger, gørende det muligt for en upriviligeret angriber at forårsage et lammelsesangreb eller forøge rettigheder.

  • CVE-2017-7541

    En bufferoverløbsfejl i WLAN-driveren Broadcom IEEE802.11n PCIe SoftMAC, kunne gøre det muligt for en lokal bruger at forårsage kernehukommelseskorruption, førende til et lammelsesangreb eller potentielt rettighedsforøgelse.

  • CVE-2017-7542

    Der blev fundet en heltalsoverløbssårbarhed i funktionen ip6_find_1stfragopt(), som gjorde det muligt for en lokal angriber, med rettigheder til at åbne raw sockets, at forårsage et lammelsesangreb.

  • CVE-2017-7889

    Tommi Rantala og Brad Spengler rapporterede at mm-undersystemet ikke på korrekt vis håndhævede beskyttelsesmekanismen CONFIG_STRICT_DEVMEM, hvilket gjorde det muligt for en lokal angriber med adgang til /dev/mem, at få fat i følsomme oplysninger eller potentielt udføre vilkårlig kode.

  • CVE-2017-9605

    Murray McAllister opdagede at DRM-driveren til VMwares virtuelle GPU'er ikke på korrekt vis initialiserede hukommelse, potentielt gørende det muligt for en lokal angriber, at få fat i følsomme oplysninger fra uinitialiseret kernehukommelse gennem et fabrikeret ioctl-kald.

  • CVE-2017-10911

    / XSA-216

    Anthony Perard fra Citrix opdagede en informationslækagefejl i Xen blkif-svarhåndteringen, gørende det muligt for en ondsindet upriviligeret gæst at få fat i følsomme oplysninger fra værten eller andre gæster.

  • CVE-2017-11176

    Man opdagede at funktionen mq_notify() ikke satte sockpointer'en til null ved start af retrylogikken. En angriber kunne drage nytte af fejlen under en brugerrumslukning af en Netlink-socket, til at forårsage et lammelsesangreb eller potentielt forårsagen anden indvirkning.

  • CVE-2017-1000363

    Roee Hay rapporterede at lp-driveren ikke på korrekt vis foretog grænsekontroller på overførte parametre, gørende det muligt for en lokal angriber med skriveadgang til kernekommandolinjeparametre, at udføre vilkårlig kode.

  • CVE-2017-1000365

    Man opdagede at parameter- og miljøpointere, ikke blev taget korrekt i betragtning i forhold til de håndhævede størrelsesbegrænsninger på parameter- og miljøstrenge overført gennem RLIMIT_STACK/RLIMIT_INFINITY. En lokal anriger kunne drage nytte af fejlen i sammenhæng med andre fejl, til at udføre vilkårlig kode.

I den gamle stabile distribution (jessie), er disse problemer rettet i version 3.16.43-2+deb8u3.

Vi anbefaler at du opgraderer dine linux-pakker.