Debians sikkerhedsbulletin

DSA-3946-1 libmspack -- sikkerhedsopdatering

Rapporteret den:
18. aug 2017
Berørte pakker:
libmspack
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 868956, Fejl 871263.
I Mitres CVE-ordbog: CVE-2017-6419, CVE-2017-11423.
Yderligere oplysninger:

Man opdagede at libsmpack, et bibliotek som anvendes til at håndtere Microsofts komprimeringsformater, ikke på korrekt vis validerede sine inddata. En fjernangriber kunne fabrikerede ondsindede CAB- eller CHM-filer, og anvende fejlen til at forårsage et lammelsesangreb gennem applikationsnedbrud eller potentielt udføre vilkårlig kode.

I den gamle stabile distribution (jessie), er disse problemer rettet i version 0.5-1+deb8u1.

I den stabile distribution (stretch), er disse problemer rettet i version 0.5-1+deb9u1.

Vi anbefaler at du opgraderer dine libmspack-pakker.