Säkerhetsbulletin från Debian

DSA-3946-1 libmspack -- säkerhetsuppdatering

Rapporterat den:
2017-08-18
Berörda paket:
libmspack
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 868956, Fel 871263.
I Mitres CVE-förteckning: CVE-2017-6419, CVE-2017-11423.
Ytterligare information:

Man har upptäckt att libsmpack, ett bibliotek för hantering av Microsoft-komprimeringsformat, inte validerar sin indata ordentligt. En fjärrangripare kunder skapa illasinnade CAB eller CHM-filer och använda denna brist för att orsaka en överbelastning via applikationskrasch, eller potentiellt köra godtycklig kod.

För den gamla stabila utgåvan (Jessie) har dessa problem rättats i version 0.5-1+deb8u1.

För den stabila utgåvan (Stretch) har dessa problem rättats i version 0.5-1+deb9u1.

Vi rekommenderar att ni uppgraderar era libmspack-paket.