Bulletin d'alerte Debian

DSA-3953-1 aodh -- Mise à jour de sécurité

Date du rapport :
23 août 2017
Paquets concernés :
aodh
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 872605.
Dans le dictionnaire CVE du Mitre : CVE-2017-12440.
Plus de précisions :

Zane Bitter de Red Hat a découvert une vulnérabilité dans Aodh, le moteur d'alerte d'OpenStack. Aodh ne vérifie pas si l'utilisateur qui crée l'alerte est l'utilisateur faisant confiance (« trustor ») ou dispose des mêmes droits que lui, ni que l'engagement de délégation (« trust ») concerne le même projet que l'alerte. Le bogue permet à un utilisateur authentifié sans jeton Keystone, connaissant les identifiants de « trusts », de réaliser des actions authentifiées non précisées en ajoutant des actions d'alerte.

Pour la distribution stable (Stretch), ce problème a été corrigé dans la version 3.0.0-4+deb9u1.

Nous vous recommandons de mettre à jour vos paquets aodh.