Debians sikkerhedsbulletin

DSA-3958-1 fontforge -- sikkerhedsopdatering

Rapporteret den:
29. aug 2017
Berørte pakker:
fontforge
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 869614.
I Mitres CVE-ordbog: CVE-2017-11568, CVE-2017-11569, CVE-2017-11571, CVE-2017-11572, CVE-2017-11574, CVE-2017-11575, CVE-2017-11576, CVE-2017-11577.
Yderligere oplysninger:

Man opdagede at FontForge, en fonteditor, ikke på korrekt vis validerede sine inddata. En angriber kunne udnytte fejlen, ved at narre en bruger til at åbne en ondsindet fabrikeret OpenType-fontfil, og dermed forårsagende et lammelsesangreb gennem applikationsnedbrud, eller udførelse af vilkårlig kode.

I den gamle stabile distribution (jessie), er disse problemer rettet i version 20120731.b-5+deb8u1.

I den stabile distribution (stretch), er disse problemer rettet i version 1:20161005~dfsg-4+deb9u1.

Vi anbefaler at du opgraderer dine fontforge-pakker.