Säkerhetsbulletin från Debian

DSA-3958-1 fontforge -- säkerhetsuppdatering

Rapporterat den:
2017-08-29
Berörda paket:
fontforge
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 869614.
I Mitres CVE-förteckning: CVE-2017-11568, CVE-2017-11569, CVE-2017-11571, CVE-2017-11572, CVE-2017-11574, CVE-2017-11575, CVE-2017-11576, CVE-2017-11577.
Ytterligare information:

Man har upptäckt att FontForge, en typsnittsredigerare, inte validerar sin indata ordentligt. En angripare kunde utnyttja denna brist genom att lura en användare att öppna en illasinnat skapad OpenType-typsnittsfil, och därmed orsaka en överbelastning via applikationskrasch, eller exekvering av godtycklig kod.

För den gamla stabila utgåvan (Jessie) har dessa problem rättats i version 20120731.b-5+deb8u1.

För den stabila utgåvan (Stretch) har dessa problem rättats i version 1:20161005~dfsg-4+deb9u1.

Vi rekommenderar att ni uppgraderar era fontforge-paket.