Рекомендация Debian по безопасности

DSA-3961-1 libgd2 -- обновление безопасности

Дата сообщения:
03.09.2017
Затронутые пакеты:
libgd2
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2017-6362.
Более подробная информация:

В функции gdImagePngPtr() из libgd2, библиотеки для создания и работы с программируемой графикой, было обнаружено двойное освобождение памяти, которое может приводить к отказу в обслуживании или потенциальному выполнению произвольного кода в случае обработки специально сформированного файла.

В предыдущем стабильном выпуске (jessie) эта проблема была исправлена в версии 2.1.0-5+deb8u11.

В стабильном выпуске (stretch) эта проблема была исправлена в версии 2.2.4-2+deb9u2.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 2.2.5-1.

Рекомендуется обновить пакеты libgd2.