Debians sikkerhedsbulletin

DSA-3962-1 strongswan -- sikkerhedsopdatering

Rapporteret den:
3. sep 2017
Berørte pakker:
strongswan
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 872155.
I Mitres CVE-ordbog: CVE-2017-11185.
Yderligere oplysninger:

En lammelsesangrebssårbarhed blev opdaget i strongSwan, en IKE-/IPsec-suite, ved hjælp af Googles OSS-Fuzz-fuzzingprojekt.

Plugin'en gmp i strongSwan havde utilstrækkelig inddatavalidering, når der blev verificeret RSA-signaturer. Programmeringsfejlen kunne føre til en nullpointerdereference, førende til et procesnedbrud.

I den gamle stabile distribution (jessie), er dette problem rettet i version 5.2.1-6+deb8u5.

I den stabile distribution (stretch), er dette problem rettet i version 5.5.1-4+deb9u1.

I distributionen testing (buster), er dette problem rettet i version 5.6.0-1.

I den ustabile distribution (sid), er dette problem rettet i version 5.6.0-1.

Vi anbefaler at du opgraderer dine strongswan-pakker.