Säkerhetsbulletin från Debian

DSA-3962-1 strongswan -- säkerhetsuppdatering

Rapporterat den:
2017-09-03
Berörda paket:
strongswan
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 872155.
I Mitres CVE-förteckning: CVE-2017-11185.
Ytterligare information:

En överbelastningssårbarhet har identifierats i strongSwan, en IKE/IPsec-uppsättning av program, vid användnign av Google's OSS-Fuzz fuzzingprojekt.

gmp-insticksmodulen i strongSwan hade otillräcklig validering av indata vid verifiering av RSA-signaturer. Detta kodningsfel kunde leda till null-pekardereferering, vilket leder till processkrasch.

För den gamla stabila utgåvan (Jessie) har detta problem rättats i version 5.2.1-6+deb8u5.

För den stabila utgåvan (Stretch) har detta problem rättats i version 5.5.1-4+deb9u1.

För uttestningsutgåvan (Buster) har detta problem rättats i version 5.6.0-1.

För den instabila distributionen (Sid) har detta problem rättats i version 5.6.0-1.

Vi rekommenderar att ni uppgraderar era strongswan-paket.