Debian e Y2K

Uno degli obiettivi di Debian è quello di fornire un sistema il più robusto possibile. Questo è il motivo per il quale abbiamo creato un sistema che si aggiorna in maniera molto semplice ed è anche il motivo per il quale stiamo investigando sulla assenza del bug dell'anno 2000, detto anche y2k.

Per valutare se un sistema soddisfa o meno il problema dell'anno 2000 non si deve solo guardare il sistema di base (il kernel e le librerie di base e gli strumenti che creano il sistema), ma tutti quegli strumenti che vengono usati ogni giorno. Non ha significato avere sistemi che sono quasi 'y2k compliant' poiché anche un sisngolo componente può causare l'arresto del vostro sistema.

Diversamente da altri tanto decantati sistemi operativi oggi sul mercato, Debian è creata aggiungendo un gran numero di strumenti sopra il kernel Linux. Questa architettura permette di aggiornare anche solo alcune parti del sistema senza incidere sulle restanti. Permette altresì di avere livelli di astrazione nel disegno che permettono poi la creazione di un sistema maggiormente robusto e flessibile. Poiché l'interazione tra i vari componenti è ben conosciuta non resta che verificare la validità dei singoli componenti.

Coem servizio per i nostri clienti, stiamo creando una lista di package e delle informazioni sul loro stato nei confronti dello Y2K. Poiché la sicurezza relativa a questo problema è maggiormente sentita nei reparti IT abbiamo deciso di dividere la lista in una sezione di base per i package relativi ai server, l'altra per tutti gli altri pacchetti (oltre 2500.)

Vai alla lista dei pacchetti optional ed extra.

[Nota: Se sei al corrente di altri link manda un messaggio al <webmaster@debian.org>]

PacchettoVersione StatoURL
adduser3.8OK --
aeTUTTIOK http://www.gnu.org/software/year2000-list.html
base-files2.0OK --
base-passwd2.0.3.3OK --
bash2.02OK http://www.gnu.org/software/year2000-list.html
bsdutils4.2.0.1OK? --
debianutils1.9OK? --
dialog0.9a-12.0OK --
diff2.7-16OK http://www.gnu.org/software/year2000-list.html
dpkg1.4.0.23.2OK --
dpkg-ftp1.4.9.6OK --
e2fsprogs1.10-17OK --
elvis-tiny1.4-5Sconosciuto --
fdflush1.0.0-12OK? --
fileutils3.16-5.3OK? http://www.gnu.org/software/year2000-list.html
findutils4.1OK http://www.gnu.org/software/year2000-list.html
grep2.1-8OK http://www.gnu.org/software/year2000-list.html
gzip1.2.4-27Sconosciuto http://www.gnu.org/software/year2000-list.html
hostname2.04OK --
kbd0.95-16Sconosciuto --
kernel-image-2.0.332.0.33-10OK http://www.linux.org.uk/mbug.html
kernel-image-2.0.342.0.34-4OK http://www.linux.org.uk/mbug.html
ldso1.9.9-1OK? --
libc62.0.7t-1OK http://www.gnu.org/software/year2000-list.html
libgdbmg11.7.3-25OK http://www.gnu.org/software/year2000-list.html
libnet-perl1.0502-1Sconosciuto ??
libreadlineg22.1-11Sconosciuto http://www.gnu.org/software/year2000-list.html
libstdc++2.82.90.29-0.6Sconosciuto http://www.gnu.org/software/year2000-list.html
lilo20-0.1Sconosciuto --
login980403-0.3Sconosciuto --
makedev1.6-32OK? --
mawk1.3.3-2Sconosciuto --
mbr1.0.0-6Sconosciuto --
modconf0.2.17OK? --
modutils2.1.85-11Sconosciuto --
mount2.7l-5OK? --
ncurses-base1.9.9g-8.10Sconosciuto --
ncurses-bin1.9.9g-8.10Sconosciuto --
ncurses3.41.9.9g-8.10Sconosciuto --
passwd980403-0.3Sconosciuto --
perl-base5.004.04-6OK http://language.perl.com/news/y2k.html
procps1:1.2.7-1Sconosciuto --
psmisc16-2Sconosciuto --
sed2.05-22OK http://www.gnu.org/software/year2000-list.html
setserial2.12-6OK? --
shellutils1.16-6OK http://www.gnu.org/software/year2000-list.html
slang0.99.380.99.38-6Sconosciuto --
sysklogd1.3-26OK? --
syslinux1.40-2.1Sconosciuto --
sysvinit2.75-3OK? --
tar1.12-6OK? http://www.gnu.org/software/year2000-list.html
textutils1.22-2.4OK http://www.gnu.org/software/year2000-list.html
timezones2.0.7t-1Sconosciuto --
update1.3-2OK? --
util-linux2.7.1-3Errato? --
util-linux2.9+OK --
whiptail0.21-8Sconosciuto --