Debian の西暦 2000 年問題

Debian の掲げる目標のひとつは、もっとも堅牢なシステムを提供すること にあります。私たちはこの目標を達成するために、完全にシームレスなアップ グレードが可能なシステムを開発し、また Debian がどの程度 Y2K compliant (西暦 2000 年問題対応) であるかを調査しているのです。

システムが西暦 2000 年問題対応しているか評価するには、基本システム (カーネル、システム構築に必要な基本ライブラリ群やツール群)だけでなく 毎日使用しているすべてのツール群について調査する必要があります。あな たの仕事に不可欠なシステムがその機能を停止させてしまうような 西暦 2000 年問題未対応コンポーネントがひとつでもあれば、システムが 「ほぼ」 2000 年問題対応していても意味がありません。

売りものになっている傲慢で画一的なオペレーティングシステムとは異なり、 Debian は Linux カーネルに多数のツール群を追加することによって成り 立っています。このような設計により、システムの一部をアップグレード する際にそれ以外のコンポーネントに影響を与えることがありません。また、 個々のコンポーネントの抽出が容易となり、より堅牢かつ柔軟なシステムを 構築することが可能になります。つまり、異なるコンポーネント間の相互関係 を十分理解していれば、それぞれのコンポーネントが 2000 年問題対応済である ことを個別にテストするだけで、システム全体が 2000 年問題対応済であると 証明することができます。

私たちは利用者へのサービスとして、パッケージ群の 2000 年問題対応状況に ついて情報を収集しています。私たちが提供する (2500 以上の)パッケージ群 の中でも 2000 年問題対応が最も重要視される、「ベース」システム パッケージ群とサーバマシンで最も利用されているコンポーネントについて 一覧表を用意しました。

optional と extra パッケージ一覧を参照する。

[注意: 他にリンクを御存じでしたら、 <webmaster@debian.org> にメールでお知らせください。]

パッケージバージョン 状況URL
adduser3.8対応 --
aeすべて対応 http://www.gnu.org/software/year2000-list.html
base-files2.0対応 --
base-passwd2.0.3.3対応 --
bash2.02対応 http://www.gnu.org/software/year2000-list.html
bsdutils4.2.0.1対応? --
debianutils1.9対応? --
dialog0.9a-12.0対応 --
diff2.7-16対応 http://www.gnu.org/software/year2000-list.html
dpkg1.4.0.23.2対応 --
dpkg-ftp1.4.9.6対応 --
e2fsprogs1.10-17対応 --
elvis-tiny1.4-5不明 --
fdflush1.0.0-12対応? --
fileutils3.16-5.3対応? http://www.gnu.org/software/year2000-list.html
findutils4.1対応 http://www.gnu.org/software/year2000-list.html
grep2.1-8対応 http://www.gnu.org/software/year2000-list.html
gzip1.2.4-27不明 http://www.gnu.org/software/year2000-list.html
hostname2.04対応 --
kbd0.95-16不明 --
kernel-image-2.0.332.0.33-10対応 http://www.linux.org.uk/mbug.html
kernel-image-2.0.342.0.34-4対応 http://www.linux.org.uk/mbug.html
ldso1.9.9-1対応? --
libc62.0.7t-1対応 http://www.gnu.org/software/year2000-list.html
libgdbmg11.7.3-25対応 http://www.gnu.org/software/year2000-list.html
libnet-perl1.0502-1不明 ??
libreadlineg22.1-11不明 http://www.gnu.org/software/year2000-list.html
libstdc++2.82.90.29-0.6不明 http://www.gnu.org/software/year2000-list.html
lilo20-0.1不明 --
login980403-0.3不明 --
makedev1.6-32対応? --
mawk1.3.3-2不明 --
mbr1.0.0-6不明 --
modconf0.2.17対応? --
modutils2.1.85-11不明 --
mount2.7l-5対応? --
ncurses-base1.9.9g-8.10不明 --
ncurses-bin1.9.9g-8.10不明 --
ncurses3.41.9.9g-8.10不明 --
passwd980403-0.3不明 --
perl-base5.004.04-6対応 http://language.perl.com/news/y2k.html
procps1:1.2.7-1不明 --
psmisc16-2不明 --
sed2.05-22対応 http://www.gnu.org/software/year2000-list.html
setserial2.12-6対応? --
shellutils1.16-6対応 http://www.gnu.org/software/year2000-list.html
slang0.99.380.99.38-6不明 --
sysklogd1.3-26対応? --
syslinux1.40-2.1不明 --
sysvinit2.75-3対応? --
tar1.12-6対応? http://www.gnu.org/software/year2000-list.html
textutils1.22-2.4対応 http://www.gnu.org/software/year2000-list.html
timezones2.0.7t-1不明 --
update1.3-2対応? --
util-linux2.7.1-3未対応? --
util-linux2.9+対応 --
whiptail0.21-8不明 --