Debian e o Ano 2000

Um dos objetivos do Debian é fornecer o sistema mais robusto possível. É por isso que nós criamos um sistema que torna a atualização simples e é também por isso que nós estamos investigando o quão compatível com o ano 2000 o Debian é.

Para examinar o quão compatível um sistema é com o ano 2000, você precisa olhar não somente a base do sistema (o kernel e as bibliotecas e ferramentas básicas que criam um sistema), mas também todas as ferramentas que você usa diariamente. A quase compatibilidade com o ano 2000 de um sistema não faz sentido se a falha de até mesmo um único componente não-compatível fizer que o seu sistema de missão crítica para de funcionar.

Ao contrário de alguns sistemas operacionais monolíticos e inchados, o Debian é criado pela adição de um grande número de ferramentas no topo do kernel Linux. Este tipo de design permite que partes do sistema sejam atualizadas sem afetar o resto. Ele permite níveis de abstração no design que criam um sistema muito mais robusto e flexível. Como a interação dos componentes é bem compreendida, nós precisamos apenas testar a compatiblidade de cada componente para verificar a compatibilidade do sistema.

Como um serviço aos nossos usuários, nós estamos coletando uma lista de pacotes e seu estado de compatibildiade com o ano 2000. Como a compatibilidade com o ano 2000 é mais importante para departamentos de TI nós separamos um lista de pacotes de 'base' do sistema e componentes mais usados por servidores do resto dos pacotes que nós fornecemos (mais de 2500).

Ir para a lista de pacotes opcionais e extras.

[Nota: Caso você saiba de algum outro link, envie uma mensagem (em inglês) para <webmaster@debian.org>]

PacoteVersão EstadoURL
adduser3.8OK --
aeTUDOOK http://www.gnu.org/software/year2000-list.html
base-files2.0OK --
base-passwd2.0.3.3OK --
bash2.02OK http://www.gnu.org/software/year2000-list.html
bsdutils4.2.0.1OK? --
debianutils1.9OK? --
dialog0.9a-12.0OK --
diff2.7-16OK http://www.gnu.org/software/year2000-list.html
dpkg1.4.0.23.2OK --
dpkg-ftp1.4.9.6OK --
e2fsprogs1.10-17OK --
elvis-tiny1.4-5Desconhecido --
fdflush1.0.0-12OK? --
fileutils3.16-5.3OK? http://www.gnu.org/software/year2000-list.html
findutils4.1OK http://www.gnu.org/software/year2000-list.html
grep2.1-8OK http://www.gnu.org/software/year2000-list.html
gzip1.2.4-27Desconhecido http://www.gnu.org/software/year2000-list.html
hostname2.04OK --
kbd0.95-16Desconhecido --
kernel-image-2.0.332.0.33-10OK http://www.linux.org.uk/mbug.html
kernel-image-2.0.342.0.34-4OK http://www.linux.org.uk/mbug.html
ldso1.9.9-1OK? --
libc62.0.7t-1OK http://www.gnu.org/software/year2000-list.html
libgdbmg11.7.3-25OK http://www.gnu.org/software/year2000-list.html
libnet-perl1.0502-1Desconhecido ??
libreadlineg22.1-11Desconhecido http://www.gnu.org/software/year2000-list.html
libstdc++2.82.90.29-0.6Desconhecido http://www.gnu.org/software/year2000-list.html
lilo20-0.1Desconhecido --
login980403-0.3Desconhecido --
makedev1.6-32OK? --
mawk1.3.3-2Desconhecido --
mbr1.0.0-6Desconhecido --
modconf0.2.17OK? --
modutils2.1.85-11Desconhecido --
mount2.7l-5OK? --
ncurses-base1.9.9g-8.10Desconhecido --
ncurses-bin1.9.9g-8.10Desconhecido --
ncurses3.41.9.9g-8.10Desconhecido --
passwd980403-0.3Desconhecido --
perl-base5.004.04-6OK http://language.perl.com/news/y2k.html
procps1:1.2.7-1Desconhecido --
psmisc16-2Desconhecido --
sed2.05-22OK http://www.gnu.org/software/year2000-list.html
setserial2.12-6OK? --
shellutils1.16-6OK http://www.gnu.org/software/year2000-list.html
slang0.99.380.99.38-6Desconhecido --
sysklogd1.3-26OK? --
syslinux1.40-2.1Desconhecido --
sysvinit2.75-3OK? --
tar1.12-6OK? http://www.gnu.org/software/year2000-list.html
textutils1.22-2.4OK http://www.gnu.org/software/year2000-list.html
timezones2.0.7t-1Desconhecido --
update1.3-2OK? --
util-linux2.7.1-3RUIM? --
util-linux2.9+OK --
whiptail0.21-8Desconhecido --