Debian Security Advisory

DLA-82-1 wget -- LTS security update

Date Reported:
03 Nov 2014
Affected Packages:
wget
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2014-4877.
More information:

HD Moore of Rapid7 discovered a symlink attack in Wget, a command-line utility to retrieve files via HTTP, HTTPS, and FTP. The vulnerability allows to create arbitrary files on the user's system when Wget runs in recursive mode against a malicious FTP server. Arbitrary file creation may override content of user's files or permit remote code execution with the user privilege.

This update changes the default setting in Wget such that it no longer creates local symbolic links, but rather traverses them and retrieves the pointed-to file in such a retrieval.

For Debian 6 Squeeze, these issues have been fixed in wget version 1.12-2.1+deb6u1