Debian Security Advisory

DLA-252-1 postgresql-8.4 -- LTS security update

Date Reported:
23 Jun 2015
Affected Packages:
postgresql-8.4
Vulnerable:
Yes
Security database references:
No other external database security references currently available.
More information:

Several bugs were discovered in PostgreSQL, a relational database server system. The 8.4 branch is EOLed upstream, but still present in Debian squeeze. This new LTS minor version contains the fixes that were applied upstream to the 9.0.22 version, backported to 8.4.22 which was the last version officially released by the PostgreSQL developers. This LTS effort for squeeze-lts is a community project sponsored by credativ GmbH.

## Migration to Version 8.4.22lts4

A dump/restore is not required for those running 8.4.X. However, if you are upgrading from a version earlier than 8.4.22, see the relevant release notes.

## Changes

  • Fix rare failure to invalidate relation cache init file (Tom Lane)

    With just the wrong timing of concurrent activity, a VACUUM FULL on a system catalog might fail to update the init file that's used to avoid cache-loading work for new sessions. This would result in later sessions being unable to access that catalog at all. This is a very ancient bug, but it's so hard to trigger that no reproducible case had been seen until recently.

For Debian 6 Squeeze, these issues have been fixed in postgresql-8.4 version 8.4.22lts4-0+deb6u1