Bulletin d'alerte Debian

DLA-467-1 xerces-c -- Mise à jour de sécurité pour LTS

Date du rapport :
12 mai 2016
Paquets concernés :
xerces-c
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 823863.
Dans le dictionnaire CVE du Mitre : CVE-2016-2099.
Plus de précisions :

La classe XMLReader peut lever une exception si un caractère non valable est rencontré et l'exception traverse les structures de piles d'une façon non sécurisée qui fait accéder un gestionnaire d'exception de haut niveau à un objet déjà libéré.

Pour Debian 6 Squeeze, ces problèmes ont été corrigés dans la version 3.1.1-3+deb7u3 de xerces-c.