Bulletin d'alerte Debian

DLA-475-1 python-tornado -- Mise à jour de sécurité pour LTS

Date du rapport :
15 mai 2016
Paquets concernés :
python-tornado
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2014-9720.
Plus de précisions :

python-tornado, un cadriciel web Python et une bibliothèque de réseau asynchrone, était vulnérable à une attaque de type BREACH (« Browser Reconnaissance and Exfiltration via Adaptive Compression of Hypertext »). Le jeton XSRF est maintenant encodé avec un masque aléatoire sur chaque requête. Cela rend en sûr l'inclusion dans des pages compressées sans qu'il soit vulnérable.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 2.3-2+deb7u1.

Nous vous recommandons de mettre à jour vos paquets python-tornado.