Debian Security Advisory

DLA-493-1 openafs -- LTS security update

Date Reported:
29 May 2016
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2015-8312, CVE-2016-2860, CVE-2016-4536.
More information:
  • CVE-2015-8312

    Off-by-one error in afs_pioctl.c in OpenAFS before 1.6.16 might allow local users to cause a denial of service (memory overwrite and system crash) via a pioctl with an input buffer size of 4096 bytes.

  • CVE-2016-2860

    The newEntry function in ptserver/ptprocs.c in OpenAFS before 1.6.17 allows remote authenticated users from foreign Kerberos realms to bypass intended access restrictions and create arbitrary groups as administrators by leveraging mishandling of the creator ID.

  • CVE-2016-4536

    The client in OpenAFS before 1.6.17 does not properly initialize the (1) AFSStoreStatus, (2) AFSStoreVolumeStatus, (3) VldbListByAttributes, and (4) ListAddrByAttributes structures, which might allow remote attackers to obtain sensitive memory information by leveraging access to RPC call traffic.

For Debian 7 Wheezy, these problems have been fixed in version 1.6.1-3+deb7u6.

We recommend that you upgrade your openafs packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: