Bulletin d'alerte Debian

DLA-592-1 postgresql-9.1 -- Mise à jour de sécurité pour LTS

Date du rapport :
11 août 2016
Paquets concernés :
postgresql-9.1
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Aucune référence à une base de données externe en rapport avec la sécurité n'est actuellement disponible.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans PostgreSQL, un système de base de données SQL.

  • CVE-2016-5423

    Karthikeyan Jambu Rajaraman a découvert que les expressions CASE-WHEN imbriquées ne sont pas correctement évaluées, menant éventuellement à un plantage ou permettant la divulgation de portions de la mémoire du serveur.

  • CVE-2016-5424

    Nathan Bossart a découvert que les caractères spéciaux dans la base de données et les noms de rôle ne sont pas correctement gérés, menant éventuellement à l'exécution de commandes avec les droits du super-utilisateur quand il exécute pg_dumpall ou d'autres opérations de maintenance de routine.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 9.1.23-0+deb7u1.

Nous vous recommandons de mettre à jour vos paquets postgresql-9.1.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.