Bulletin d'alerte Debian

DLA-598-1 suckless-tools -- Mise à jour de sécurité pour LTS

Date du rapport :
20 août 2016
Paquets concernés :
suckless-tools
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2016-6866.
Plus de précisions :

L'outil de verrouillage d'écran slock pourrait être victime d'une erreur de segmentation quand le compte de l'utilisateur a été désactivé.

slock appelait crypt(3) et utilisait la valeur de retour pour strcmp(3) sans vérifier si la valeur de retour de crypt(3) était un pointeur NULL. Si le hachage renvoyé par (getspnam()->sp_pwdp) n'était pas valable, crypt(3) pourrait renvoyer NULL et régler errno à EINVAL. Cela pourrait provoquer une erreur de segmentation de slock qui laisse la machine sans protection.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 38-2+deb7u1 de suckless-tools.

Nous vous recommandons de mettre à jour vos paquets suckless-tools.