Debian Security Advisory

DLA-601-1 quagga -- LTS security update

Date Reported:
27 Aug 2016
Affected Packages:
quagga
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 835223, Bug 822787.
In Mitre's CVE dictionary: CVE-2016-4036, CVE-2016-4049.
More information:

The quagga package installs world readable sensitive files in /etc/quagga, and might be subject to denial of service because of lacking packet size checks.

  • CVE-2016-4036

    The quagga package before 0.99.23-2.6.1 uses weak permissions for /etc/quagga, which allows local users to obtain sensitive information by reading files in the directory.

  • CVE-2016-4049

    The bgp_dump_routes_func function in bgpd/bgp_dump.c in Quagga does not perform size checks when dumping data, which might allow remote attackers to cause a denial of service (assertion failure and daemon crash) via a large BGP packet.

For Debian 7 Wheezy, these problems have been fixed in version 0.99.22.4-1+wheezy3.

We recommend that you upgrade your quagga packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS