Debian Security Advisory

DLA-643-1 chicken -- LTS security update

Date Reported:
30 Sep 2016
Affected Packages:
chicken
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2016-6830, CVE-2016-6831.
More information:

Multiple vulnerabilities have been found in the CHICKEN Scheme compiler:

  • CVE-2016-6830

    Buffer overrun in CHICKEN Scheme's "process-execute" and "process-spawn" procedures from the posix unit

  • CVE-2016-6831

    Memory leak in CHICKEN Scheme's process-execute and process-spawn procedures

For Debian 7 Wheezy, these problems have been fixed in version 4.7.0-1+deb7u1.

We recommend that you upgrade your chicken packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS