Bulletin d'alerte Debian

DLA-669-1 dwarfutils -- Mise à jour de sécurité pour LTS

Date du rapport :
19 octobre 2016
Paquets concernés :
dwarfutils
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2015-8538, CVE-2015-8750, CVE-2016-2050, CVE-2016-2091, CVE-2016-5034, CVE-2016-5036, CVE-2016-5038, CVE-2016-5039, CVE-2016-5042.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans dwarfutils, un outil et une bibliothèque pour lire ou interpréter et écrire ou produire des informations de débogage de DWARF. Le projet « Common Vulnerabilities and Exposures » (CVE) identifie les problèmes suivants.

  • CVE-2015-8538

    Un fichier ELF contrefait pour l'occasion peut provoquer une erreur de segmentation.

  • CVE-2015-8750

    Un fichier ELF contrefait pour l'occasion peut provoquer un déréférencement de pointeur NULL.

  • CVE-2016-2050

    Écriture hors limites.

  • CVE-2016-2091

    Lecture hors limites.

  • CVE-2016-5034

    Écriture hors limites.

  • CVE-2016-5036

    Lecture hors limites.

  • CVE-2016-5038

    Lecture hors limites.

  • CVE-2016-5039

    Lecture hors limites

  • CVE-2016-5042

    Une section DWARF contrefaite pour l'occasion peut provoquer une boucle infinie, en lisant à partir d'adresses de mémoire croissantes jusqu'au plantage de l'application.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 20120410-2+deb7u2.

Nous vous recommandons de mettre à jour vos paquets dwarfutils.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.