Debian Security Advisory

DLA-675-1 potrace -- LTS security update

Date Reported:
26 Oct 2016
Affected Packages:
potrace
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2013-7437, CVE-2016-8694, CVE-2016-8695, CVE-2016-8696, CVE-2016-8697, CVE-2016-8698, CVE-2016-8699, CVE-2016-8700, CVE-2016-8701, CVE-2016-8702, CVE-2016-8703.
More information:

Multiple vulnerabilities have been found in potrace.

  • CVE-2013-7437

    Multiple integer overflows in potrace 1.11 allow remote attackers to cause a denial of service (crash) via large dimensions in a BMP image, which triggers a buffer overflow. This bug was reported by Murray McAllister of the Red Hat Security Response Team.

  • CVE-2016-8694 / CVE-2016-8695 / CVE-2016-8696

    Multiple NULL pointer dereferences in bm_readbody_bmp. This bug was discovered by Agostino Sarubbo of Gentoo.

  • CVE-2016-8697

    Division by zero in bm_new. This bug was discovered by Agostino Sarubbo of Gentoo.

  • CVE-2016-8698 / CVE-2016-8699 / CVE-2016-8700 / CVE-2016-8701 / CVE-2016-8702 / CVE-2016-8703

    Multiple heap-based buffer overflows in bm_readbody_bmp. This bug was discovered by Agostino Sarubbo of Gentoo.

For Debian 7 Wheezy, these problems have been fixed in version 1.10-1+deb7u1.

We recommend that you upgrade your potrace packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS