Debian Security Advisory

DLA-698-1 qemu -- LTS security update

Date Reported:
03 Nov 2016
Affected Packages:
qemu
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 839834, Bug 841950, Bug 841955, Bug 842455, Bug 842463.
In Mitre's CVE dictionary: CVE-2016-7909, CVE-2016-8909, CVE-2016-8910, CVE-2016-9101, CVE-2016-9102, CVE-2016-9103, CVE-2016-9104, CVE-2016-9105, CVE-2016-9106.
More information:

Several vulnerabilities were discovered in qemu, a fast processor emulator. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2016-7909

    Quick Emulator(Qemu) built with the AMD PC-Net II emulator support is vulnerable to an infinite loop issue. It could occur while receiving packets via pcnet_receive().

    A privileged user/process inside guest could use this issue to crash the Qemu process on the host leading to DoS.

  • CVE-2016-8909

    Quick Emulator(Qemu) built with the Intel HDA controller emulation support is vulnerable to an infinite loop issue. It could occur while processing the DMA buffer stream while doing data transfer in intel_hda_xfer.

    A privileged user inside guest could use this flaw to consume excessive CPU cycles on the host, resulting in DoS.

  • CVE-2016-8910

    Quick Emulator(Qemu) built with the RTL8139 ethernet controller emulation support is vulnerable to an infinite loop issue. It could occur while transmitting packets in C+ mode of operation.

    A privileged user inside guest could use this flaw to consume excessive CPU cycles on the host, resulting in DoS situation.

  • CVE-2016-9101

    Quick Emulator(Qemu) built with the i8255x (PRO100) NIC emulation support is vulnerable to a memory leakage issue. It could occur while unplugging the device, and doing so repeatedly would result in leaking host memory affecting, other services on the host.

    A privileged user inside guest could use this flaw to cause a DoS on the host and/or potentially crash the Qemu process on the host.

  • CVE-2016-9102 / CVE-2016-9105 / CVE-2016-9106

    Quick Emulator(Qemu) built with the VirtFS, host directory sharing via Plan 9 File System(9pfs) support, is vulnerable to a several memory leakage issues.

    A privileged user inside guest could use this flaws to leak the host memory bytes resulting in DoS for other services.

  • CVE-2016-9104

    Quick Emulator(Qemu) built with the VirtFS, host directory sharing via Plan 9 File System(9pfs) support, is vulnerable to an integer overflow issue. It could occur by accessing xattributes values.

    A privileged user inside guest could use this flaw to crash the Qemu process instance resulting in DoS.

  • CVE-2016-9103

    Quick Emulator(Qemu) built with the VirtFS, host directory sharing via Plan 9 File System(9pfs) support, is vulnerable to an information leakage issue. It could occur by accessing xattribute value before it's written to.

    A privileged user inside guest could use this flaw to leak host memory bytes.

For Debian 7 Wheezy, these problems have been fixed in version 1.1.2+dfsg-6+deb7u18.

We recommend that you upgrade your qemu packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS