Debian Security Advisory

DLA-707-1 sudo -- LTS security update

Date Reported:
14 Nov 2016
Affected Packages:
sudo
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 842507.
In Mitre's CVE dictionary: CVE-2016-7032, CVE-2016-7076.
More information:

It was discovered that the sudo noexec restriction could have been bypassed if application run via sudo executed system(), popen() or wordexp() C library functions with a user supplied argument. A local user permitted to run such application via sudo with noexec restriction could possibly use this flaw to execute arbitrary commands with elevated privileges.

For Debian 7 Wheezy, these problems have been fixed in version 1.8.5p2-1+nmu3+deb7u2.

We recommend that you upgrade your sudo packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS