Debian Security Advisory

DLA-763-1 squid3 -- LTS security update

Date Reported:
25 Dec 2016
Affected Packages:
squid3
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 848493.
In Mitre's CVE dictionary: CVE-2016-10002.
More information:

Saulius Lapinskas from Lithuanian State Social Insurance Fund Board discovered that Squid3, a fully featured web proxy cache, does not properly process responses to If-None-Modified HTTP conditional requests, leading to client-specific Cookie data being leaked to other clients. A remote attacker can take advantage of this flaw to discover private and sensitive information about another client's browsing session.

For Debian 7 Wheezy, these problems have been fixed in version 3.1.20-2.2+deb7u7.

We recommend that you upgrade your squid3 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS