Bulletin d'alerte Debian

DLA-1029-1 libmtp -- Mise à jour de sécurité pour LTS

Date du rapport :
17 juillet 2017
Paquets concernés :
libmtp
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2017-9831, CVE-2017-9832.
Plus de précisions :

Libmtp, une bibliothèque pour communiquer avec les appareils gérant MTP (tels les téléphones cellulaires et les lecteurs de musique), a été découverte comme étant sensible à plusieurs vulnérabilités de dépassement d'entier qui permettent à des appareils malveillants de provoquer un déni de service par plantage et peut être une exécution de code à distance.

  • CVE-2017-9831

    Une vulnérabilité de dépassement d’entier dans la fonction ptp_unpack_EOS_CustomFuncEx du fichier ptp-pack.c de libmtp (version 1.1.12 et antérieures) permet à des attaquants de provoquer un déni de service (accès en mémoire hors limites) ou une exécution possible de code à distance par insertion d’un appareil mobile dans un ordinateur personnel à l’aide d’un câble USB.

  • CVE-2017-9832

    Une vulnérabilité de dépassement d’entier dans ptp-pack.c (fonction ptp_unpack_OPL) de libmtp (version 1.1.12 et antérieures) permet à des attaquants de provoquer un déni de service (accès en mémoire hors limites) ou une exécution possible de code à distance par insertion d’un appareil mobile dans un ordinateur personnel à l’aide d’un câble USB.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 1.1.3-35-g0ece104-5+deb7u1.

Nous vous recommandons de mettre à jour vos paquets libmtp.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.