Bulletin d'alerte Debian

DLA-1036-1 gsoap -- Mise à jour de sécurité pour LTS

Date du rapport :
24 juillet 2017
Paquets concernés :
gsoap
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2017-9765.
Plus de précisions :

Une vulnérabilité a été découverte dans gsoap, une bibliothèque pour le développement de services et clients web de SOAP qui peut être exposée à un message XML spécifique de plus de 2 GB. Après la réception de ce message de 2 GB, un dépassement de tampon peut provoquer un plantage d’un serveur ouvert non sécurisé. Les clients communicant par HTTPS avec des serveurs fiables ne sont pas touchés.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 2.8.7-2+deb7u1.

Nous vous recommandons de mettre à jour vos paquets gsoap.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.