Bulletin d'alerte Debian

DLA-831-1 gtk-vnc -- Mise à jour de sécurité pour LTS

Date du rapport :
20 février 2017
Paquets concernés :
gtk-vnc
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 854450.
Dans le dictionnaire CVE du Mitre : CVE-2017-5884, CVE-2017-5885.
Plus de précisions :

Josef Gajdusek a découvert deux vulnérabilités dans gtk-vnc, un composant graphique de visualisation VNC pour GTK :

  • CVE-2017-5884

    Correction de vérification de limites pour les encodages RRE, hextile et copyrec. Ce bogue permettait à un serveur distant de provoquer un déni de service par dépassement de tampon à l'aide d'un message soigneusement contrefait contenant des sous-rectangles en dehors de la zone de dessin.

  • CVE-2017-5885

    Validation correcte des index de plage de carte de couleurs. Ce bogue permettait à un serveur distant de provoquer un déni de service par dépassement de tampon à l'aide d'un message soigneusement contrefait avec des valeurs de couleur hors plage.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 0.5.0-3.1+deb7u1.

Nous vous recommandons de mettre à jour vos paquets gtk-vnc.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.