Bulletin d'alerte Debian

DLA-883-1 curl -- Mise à jour de sécurité pour LTS

Date du rapport :
4 avril 2017
Paquets concernés :
curl
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2017-7407.
Plus de précisions :

Il existait une vulnérabilité de lecture excédentaire de tampon dans curl, un outil pour télécharger des fichiers à partir d’Internet, etc.

Si un « % » terminait un paramètre --write-out, le NUL de fin de chaîne était omis et un accès mémoire après la fin du tampon était possible et, éventuellement, la fin pouvait être affichée comme partie de la sortie.

Pour Debian 7 Wheezy, ce problème a été corrigé dans la version 7.26.0-1+wheezy18+deb7u1 de curl.

Nous vous recommandons de mettre à jour vos paquets curl.