Debian Security Advisory

DLA-893-1 bouncycastle -- LTS security update

Date Reported:
10 Apr 2017
Affected Packages:
bouncycastle
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2015-6644.
More information:

An information disclosure vulnerability was discovered in Bouncy Castle, a Java library which consists of various cryptographic algorithms. The Galois/Counter mode (GCM) implementation was missing a boundary check that could enable a local application to gain access to user's private information.

For Debian 7 Wheezy, these problems have been fixed in version 1.44+dfsg-3.1+deb7u2.

We recommend that you upgrade your bouncycastle packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS