Debian Security Advisory

DLA-925-1 kedpm -- LTS security update

Date Reported:
29 Apr 2017
Affected Packages:
kedpm
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 860817.
In Mitre's CVE dictionary: CVE-2017-8296.
More information:

An information disclosure vulnerability was found in kedpm, a password manager compatible with the figaro password manager file format. The history file can reveal the master password if it is provided on the commandline. The name of entries created or read in the password manager are also exposed in the history file.

For Debian 7 Wheezy, the master password disclosure issue has been fixed in version 0.5.0-4+deb7u1. The entries issues has not been fixed as it requires a rearchitecture of the software.

We recommend that you upgrade your kedpm packages. Note that kedpm has been removed from the upcoming Debian release ("stretch") and you should migrate to another password manager as kedpm was abandoned.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS

For Debian 6 Squeeze, these issues have been fixed in kedpm version 0.5.0-4+deb7u1