Bulletin d'alerte Debian

DLA-928-1 libsndfile -- Mise à jour de sécurité pour LTS

Date du rapport :
29 avril 2017
Paquets concernés :
libsndfile
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 860255.
Dans le dictionnaire CVE du Mitre : CVE-2015-7805, CVE-2017-7585, CVE-2017-7586, CVE-2017-7741, CVE-2017-7742.
Plus de précisions :

Plusieurs vulnérabilités ont été trouvées dans libsndfile, une bibliothèque populaire pour lire ou écrire des fichiers audio.

  • CVE-2017-7585

    Dans libsndfile avant 1.0.28, une erreur dans la fonction « flac_buffer_copy() » (flac.c) peut être exploitée afin de provoquer un dépassement de pile à l'aide d'un fichier FLAC contrefait spécialement.

  • CVE-2017-7586

    Dans libsndfile avant 1.0.28, une erreur dans la fonction « header_read() » (common.c) lors du traitement d’étiquettes ID3 peut être exploitée afin de provoquer un dépassement de pile à l'aide d'un fichier FLAC contrefait spécialement.

  • CVE-2017-7741

    Dans libsndfile avant 1.0.28, une erreur dans la fonction « flac_buffer_copy() » (flac.c) peut être exploitée afin de provoquer une violation de segmentation (avec accès en écriture mémoire) à l'aide d'un fichier FLAC contrefait spécialement lors d’une tentative de rééchantillonnage, un problème similaire à CVE-2017-7585.

  • CVE-2017-7742

    Dans libsndfile avant 1.0.28, une erreur dans la fonction « flac_buffer_copy() » (flac.c) peut être exploitée afin de provoquer une violation de segmentation (avec accès en lecture mémoire) à l'aide d'un fichier FLAC contrefait spécialement lors d’une tentative de rééchantillonnage, un problème similaire à CVE-2017-7585.

  • CVE-2014-9496

    La fonction sd2_parse_rsrc_fork dans sd2.c dans libsndfile permet à des attaquants d’avoir un impact non précisé à l’aide de vecteurs relatifs à (1) un décalage de mappage ou (2) Qrsrc marker, qui déclenche une lecture hors limites.

  • CVE-2014-9756

    La fonction psf_fwrite dans file_io.c dans libsndfile permet à des attaquants de provoquer un déni de service (erreur de division par zéro et plantage d'application) à l’aide de vecteurs non précisés relatifs à la variable headindex.

  • CVE-2015-7805

    Un dépassement de tampon basé sur le tas dans libsndfile 1.0.25 permet à des attaquants distants d’avoir un impact non précisé à l’aide d’une valeur headindex dans l’en-tête d’un fichier AIFF.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 1.0.25-9.1+deb7u1.

Nous vous recommandons de mettre à jour vos paquets libsndfile.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.