Bulletin d'alerte Debian

DLA-1240-1 ming -- Mise à jour de sécurité pour LTS

Date du rapport :
11 janvier 2018
Paquets concernés :
ming
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2017-11732, CVE-2017-16883, CVE-2017-16898.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans Ming :

  • CVE-2017-11732

    une vulnérabilité de dépassement de tas dans la fonction dcputs (util/decompile.c) dans Ming <= 0.4.8. Cela permet à des attaquants de provoquer un déni de service à l'aide d'un fichier SWF contrefait.

  • CVE-2017-16883

    une vulnérabilité de déréférencement de pointeur NULL dans la fonction outputSWF_TEXT_RECORD (util/outputscript.c) dans Ming <= 0.4.8. Cela permet à des attaquants de provoquer un déni de service à l'aide d'un fichier SWF contrefait.

  • CVE-2017-16898

    une vulnérabilité de dépassement de tampon global dans la fonction printMP3Headers (util/listmp3.c) dans Ming <= 0.4.8. Cela permet à des attaquants de provoquer un déni de service à l'aide d'un fichier SWF contrefait.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 1:0.4.4-1.1+deb7u6.

Nous vous recommandons de mettre à jour vos paquets ming.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS