Debian Security Advisory

DLA-1249-1 smarty3 -- LTS security update

Date Reported:
19 Jan 2018
Affected Packages:
smarty3
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2017-1000480.
More information:

It was discovered that there was a code-injection vulnerability in smarty3, a PHP template engine.

A via specially-crafted filename in comments could result in arbitray code execution. Thanks to Mike Gabriel for backporting the patch.

For Debian 7 Wheezy, this issue has been fixed in smarty3 version 3.1.10-2+deb7u2.

We recommend that you upgrade your smarty3 packages.