Bulletin d'alerte Debian

DLA-1253-1 openocd -- Mise à jour de sécurité pour LTS

Date du rapport :
21 janvier 2018
Paquets concernés :
openocd
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 887488.
Dans le dictionnaire CVE du Mitre : CVE-2018-5704.
Plus de précisions :

OpenOCD, une solution libre sur puce de débogage JTAG pour les systèmes ARM et MIPS, ne bloque pas les tentatives d'utilisation de HTTP POST pour envoyer des données à localhost. Cela permet à des attaquants distants de conduire des attaques par script interprotocole(« Cross Protocol Scripting ») et, en conséquence, d'exécuter des commandes arbitraires à l'aide d'un site web contrefait.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 0.5.0-1+deb7u1.

Nous vous recommandons de mettre à jour vos paquets openocd.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.